
 
 

New features in Family Tree Builder 6.0 
Last update: December 20, 2011 

Major new features 

 

1. Added a new research facility through WorldVitalRecords.com now owned by 

MyHeritage.com. Get information from our new database of historical records containing 

billions of birth, marriage, death and census records, plus newspapers, yearbooks and 

additional historical content. 

 

o Family Tree builder automatically searches for information in the online database. 

If records are found for a person in your tree, an icon or button is shown in the 

person’s card in the Tree view. 

o Click this icon or button to see the actual results in our website. A separate 

WorldVitalRecords subscription is required but you can look at records for free 

under a free trial. 

o You can also use the right-click menu on a person, or the Research menu, to 

perform research. 

o The automatic research feature can be turned off in 

Tools>Options>General>Automatic Record Search 

 

2. Added convenient, seamless integration with your family site on MyHeritage.com. You 

can now easily access pages in the family site that your Family Tree Builder project is 

published to: 

 

o Family Timeline: 
See your family's events and photos in an attractive, fun-to-use timeline. 

All your events, photos and videos that are dated will appear on the timeline! 

Zoom in from a century to a single day. 

Compare your family's timeline with historical events. 

The Timeline looks best in Premium and PremiumPlus family sites. 

o Family Timebook: 
The Timebook is a digital album of family photos, which includes automatically 

generated biographies for direct relatives. 

Clever technology generates a beautiful book that appears to have been prepared 

and edited in meticulous manual effort. 

The Timebook looks best in PremiumPlus family sites. 



o Profile Pages: 
Profile Pages enable you to document and celebrate the depth and diversity of 

your family history. 

They beautifully display all information about a person in one place, with photos, 

close family relatives, events, citations and much more. 

When viewing a profile, double-click any person in the list on the side to view 

that person's profile instantly. 

o Family Statistics: 

MyHeritage.com analyzes your family tree and produces 45 beautiful, 

enlightening statistics like average lifespan and most commonly used first names 

in your family. 

You'll also find many unique stats not available anywhere else. It's all free. 

o Family Events: 
Your family site is the best place to keep track of family events. 

See all upcoming family events in a list or monthly view. 

Order a beautiful personalized family calendar in a few clicks, delivered to your 

home. 

Optionally get reminders by email or free text messages (SMS). 

Never miss an important family birthday or anniversary again. 

o Family Memory Game: 

This unique free online game automatically generates beautiful personalized 

picture cards of close relatives and ancestors - based on your family tree. 

Following the same rules as a typical memory card game, users can play in 

competition with each other, or against the clock. 

Played by the young and old alike, the game is ideal for educating the younger 

generation about their ancestors and introducing them to the fascinating hobby of 

genealogy. 

o Quick visit to family site: 
Family sites are free. There are premium subscription plans for huge family trees 

or photo collections but you don't have to use them if you don't want to. 

Minor features 

1. Simplified publishing: 

o Each project can now be published into one family site at most. 

o Improved dialog that explains the benefits of publishing. 

 

New features in Family Tree Builder 5.1 

Last update: May 21, 2011 

Major new features 

1. New genealogy file importer 

o The program's file importer was enhanced. In addition to importing GEDCOM 

files and Family Tree Legends (FTL) files, you can now directly import family 

tree files from 4 additional genealogy programs. This allows you to move over 



family tree data with photos from other programs directly to Family Tree Builder 

without losing information or going through GEDCOM export/import. This is 

especially useful if you no longer have or are no longer using the software used to 

produce the family tree files.  

Support was added for importing Family Tree Maker files (FTW, FTM or FTMB 

file extensions), Personal Ancestral File files (PAF extension), Legacy files (FDB 

extension) and The Master Genealogist projects (TMG, PJC or VER extensions). 

Importing family tree files directly from other programs is based on 

GenBridge(tm) technology under license from Wholly Genes, Inc. This new 

functionality is available from the "Import GEDCOM or genealogy file" entry in 

the File menu 

o New super-fast scan tool was added for finding lost genealogy files on your 

computer. Also available from the "Import GEDCOM or genealogy file" entry in 

the File menu, you can have Family Tree Builder scan your computer for all 

family tree files (of different programs) and then select which one to import into 

Family Tree Builder 

 

New features in Family Tree Builder 5.0 

Last update: November 1, 2010 

Major new features 

1. Better charting 

o Added a Chart Wizard that makes it easy to create a chart from any of the chart 

types and styles available 

o New chart: Bowtie Chart 

o New chart: Hourglass Chart 

o Beautiful new chart format: stylish charts, with 4 exciting new designs and no 

boxes to confine your chart 

o Better fan charts that can also be saved to PDF and conform to your printer page 

settings 

o Dozens of new box borders and chart frames to pick from 

o All graphics do not make the program installer larger, as it is now able to 

download graphic updates on the fly whenever new updates are available 

o Better formatting of fact labels and values in charts 

o It is now possible to include notes in charts, as well as residence addresses 

o New huge personal photo size for charts, when photos play an important part 

o Beautiful new title decorations 

o Beautiful new tiled backgrounds 

o Beautiful new full-page backgrounds 

o Ability to create and save custom chart styles and reuse them in the future 

o New, automatic algorithm for picking title and footer font sizes 

o When saving a chart to PDF it is possible to create a hi-resolution PDF file for 

printing, or a low-resolution file which is easier to email because of its lower size 

but contains less detail 



o A new option was added to the General tab of the chart options dialog. This is the 

default and only option that existed before. Unchecking this option, will not take 

into account the printer page size and instead will create a chart that spans a single 

page of any size. This option was added to support poster printing in the future 

o Charts now show multiple occurrences of each fact, e.g. multiple occupations of a 

person, if applicable, and not just the first one. 

 

2. Chart poster printing built-into the program (create a PDF, order it as printed poster from 

MyHeritage). The user can pick the paper size (several magnifications are made possible 

based on the size of the chart and the size of the papers provided by the printing facility); 

the paper quality, based on the papers provided by the printing facility; whether to 

laminate the chart; where to ship the chart and whether to use regular or express shipping. 

3. Tree Consistency Checker (free!!) – major feature that helps you find mistakes in your 

data in almost 40 categories; guaranteed to help you improve YOUR tree, catching 

mistakes that no other genealogy program or service can. 

4. Better privacy controls: 

o Ability to prevent online publishing of specific people, specific notes, specific 

facts, or certain facts for all people 

o See all info that is privatized at a glance 

o Ability to hide privatized info from charts and reports 

o Ability to exclude privatized info from GEDCOM exports 

o A new icon designates people who have been made private for quick 

identification 

5. To-Do lists to enter tasks that need to be done and associate them with people and with 

locations; organize the next steps you need to do in your research and prioritize them. 

Find all tasks associate with a certain person or location to conduct your genealogy 

research much more effectively. 

6. Export custom report to Excel with fields you pick for the people you select. 

7. Ability to restore published trees from online family sites, via convenient wizard (File > 

Restore project > Restore from online family site). Also added the ability to restore 

published photos from any published project, by going to Photos in the program and then 

selecting Photos > Restore photos from family site. Also made it possible to restore a 

Family Tree Builder project from a family tree that was built online on MyHeritage.com 

(and not through Family Tree Builder) and even restore the photos added to it. 

8. Search & Replace functionality in almost every field in the family tree, with multiple 

configuration options, like matching case, matching an entire word, or any part of the 

text, etc., and selection of the fields that will participate in the operation. 

 

Minor features 

1. When importing a GEDCOM file, there is now a new wizard page that asks the user to 

identify himself/herself in the tree. This helps set the home person of the project as the 

individual who is the user, to give the user a better experience with the tree. 

2. URLs entered are automatically displayed as clickable links (also URLs supported for 

source citations) 



3. More configuration options: 

o Book reports can be configured to produce a report according to the page size of 

your printer 

o Book reports can be configured whether to display last names the way FTB does 

4. Improved the look of some icons throughout the program 

5. Added more icon indicators on person cards in tree view: private person, has to-do tasks, 

research completed 

6. Added new "More" tab when editing a person to add room for new properties 

7. Added info to photo tooltips including their dimensions, type and file size 

8. Quick access from the Help menu to the online FAQ and help center on MyHeritage.com 

9. Updated user guide 

10. The email address of the user currently logged on, is displayed in the window title for 

convenience 

11. There is a new configurable display option that, when enabled, shows people's ages in the 

person cards of Tree View 

12. Users who download Family Tree Builder from MyHeritage.com when they are logged 

on, will get a personalized installer that automatically registers Family Tree Builder for 

them and selects its language, so they do not have to manually go through these steps. 

This reduces the chance of errors such as registering Family Tree Builder with a mistyped 

email address. 

13. Add a new function in Tools > Options > General to restore browser search settings, that 

the program’s installer may have modified. 

 

New features for professional genealogists 

1. It is now possible to associate photos with sources. Perfect for sources that are 

documents, as now you can add a scan of the document and attach it to the source record. 

2. It is now possible to state a date for each residence of a person (so if a person lived in 

multiple addresses you can specify when he lived in each one). This is supported in the 

GEDCOM specification but there was no data entry support for it until now. 

3. Get warned when adding new people to the tree if they apparently already exist; this can 

protect you from adding duplicate people and messing up your tree; helpful when cousins 

marry, too, to keep them in the tree once. 

4. Find duplicates in your family tree (useful after merging in another family tree or finding 

duplicates that already exist). 

5. Enter DNA marker info for individuals, with perhaps the most extensive DNA entry 

facilities available on any genealogy product. 

6. There is a new setting in the Options > Names section, which allows the user to specify 

whether married names of women should be calculated from the husband's last name. 

7. Added support for married names for men too. 

8. There is a new configurable display option, whether or not to display suffix in names 

(like Jr., Sr. and II), similar to the option on whether or not to display prefix in names 

(like Dr., Prof., etc). 

9. Ability to mark a person as research-complete and easily find the people whose research 

has been completed or not completed. 



10. Better handling of sources and citations: in source list it is possible to do a quick search, 

useful for finding a source if you have many. In citation page when selecting a source, 

there is a new source selector for that which is more flexible than the pull-down list that 

existed before. 

11. Added support for specifying known number of children per family. 

 


