25    Nov 20101 comment

Photos

Search for your ancestors:

Comments (1) Trackbacks (0)
  1. I have a very old PAF Family Records 2.1 purchased in 1988 which is run on an old Mac System 7.5. I was oniphg to update to my new eMac, but find no software available. Also, don't know how to get my old stuff off to be used on ANY system. Any help for me?

Leave a comment

Submit

Please type a comment
Please enter a name
Please enter an email address

No trackbacks yet.

About us  |  Contact us  |  Privacy  |  Tell a friend  |  Support  |  Site map
Copyright © 2014 MyHeritage Ltd., All rights reserved